USB-Treiber für mp3-Player geht nicht

  • Hallo WIN 98-Fans,
    sind alle Schulkinder schlauer als ich oder haben sie neuere Betriebssysteme, bei denen man keine Treiber über USB installieren muss, um den neu erworbenen mp3-Player auch benutzen zu können???
    Habe: WIN 98 SE, zwei USB1.0- Anschlüsse; betreibe über den einen problemlos einen Canon i550-Drucker, der andere wurde bisher umgesteckt zwischen Digitaler Kamera (Fuji Fine Pix S 304), einer externen Festplatte (80GB), einem Scanner und manchmal auch der Telefonanlage.
    NEU Gekauft habe ich einen mp3-Player "Trekstor i-beat fun" mit 256 MB.
    Laut Anleitung benötigt man für WIN 98 einen Treiber, der als zip-File von der homepage herunterzuladen ging. Expandieren ging auch noch, es gibt aber keine setup.exe.
    Dafür folgende acht Dateien:
    STUmsPdr
    StUms
    StMp3Recnt
    StMp3rec
    StMp3Rec.sys
    StUms
    StUms.sys
    StUmsPdr.pdr
    Nach Auskunft des Supports sollte ich den Player trotzdem erstmal anschließen, im Gerätemanager schauen, wo ein ! oder ?-Zeichen zu finden ist und den zugehörigen Treiber mit den runtergeladenen Dateien erneuern.
    PROBLEM: Unter den "Festplattencontrollern" erscheint ein Eintrag "Digital Camera DISK device" mit einem gelben Ausrufezeichen, aber dort lässt sich KEIN Treiber aktualisieren ("bester Treiber schon vorhanden"). Außerdem ist ein mp3-Player meines Wissens KEINE Digitalkamera!
    Beim Anschließen wird gleichzeitig unter USB Contoller ein "Mass Storage Driver" angezeigt. Auch dessen Treiber lässt sich nicht erneuern.
    Verstehe die Logik der USB-Anschließerei (wie Ihr wahrscheinlich merkt?) nicht wirklich.
    Ist denn hier noch jemand in der Lage meiner Schilderung zu folgen und mal die eine oder andere Vermutung zu äußern, ob der Mp3-Player anschließbar ist, oder ob ich das Ding besser gegen einen einfacher erkennbaren umtauschen sollte?
    Vielen Dank im Voraus


    Bernd

  • Re: USB-Treiber für mp3-Player geht nicht


    Hallo!
    Nimm mal alle anderen USB-Geräte raus und lösch den installierten Treiber...
    danach neu starten
    den mp3 Player an den Pc anschließen, dann müsste ja eine meldung kommen:
    Neue Hardware gefunden
    dann kommt die Treibersuche
    Da soll der nicht automatisch danach suchen, sondern manuell angeben, wo der suchen soll,
    (da dann natürlich den ordener, wo die Treiber drin sind)
    Dann müsste der Pc die selber installiern
    und du kannst den Player benutzen...


    mfg Robin

  • Re: USB-Treiber für mp3-Player geht nicht


    Hm, die Vorgehensweise nach dem Neustart mit "neue Hardware gefunden" und manueller Angabe der Treiberdateien schlug der Support-Mensch auch vor, ABER:
    :question: Welchen bzw. welche Treiber der USB-Geräte sollte ich zuvor (vorübergehend) entfernen: ALLE???
    Es hatte bei der Installation meiner externen Festplatte ähnliche Probleme gegeben und ich weiß nicht mehr genau, welcher Treiber sie unterstützt. Ich glaube, dass ich durch das damalige Ausprobieren verschiedener Treiber einige überflüssige installiert haben müsste.
    :question: Wie kann ich herausfinden, welchen installierten Treiber ich für welches Gerät WIRKLICH benötige?
    Falls ich also einen oder alle Treiber lösche: Wie ist die eleganteste Methode sie später zu reanimieren, wenn ich (noch) nicht genau weiß, woher ich deren erneutes setup bekomme?


    Bernd

  • Re: USB-Treiber für mp3-Player geht nicht


    Hallo.
    Nein, du sollst nur den MP3-Treiber löschen und alle USB-Kabel außer dein MP3-Player rausziehen. Dann installierst du den Treiber neu. Bis Bald Paul


    Editiert am 30/1/2006 von wodnik91

    Haben Sie Lust auf Ferienwohnungen in Masuren?
    Bitte melden Sie sich an, um diesen Link zu sehen.
    7 Ultimate 32 bit
    500 GB#GA-P35-DS4 Rev. 2.0#Intel C2D 2,4GHz
    HIS HD3850 IceQ 3 Turbo 512 MB
    2 GB RAM
    16MB/s#FF 3.x


    bzw.


    IBM Thinkpad T61 | 2x2,2 GHz | 4 GB RAM | VISTA Ultimate 64 bit MCE | NVIDIA Quadro NVS 140M 128 MB | Wlan (agn) | Bluetooth 2.0

  • Re: USB-Treiber für mp3-Player geht nicht


    Hallo nochmal!
    Langsam wirds blöd: ;( Habe nach Robins und Pauls Tipps alle Kabel rausgezogen, die beiden merkwürdigen Einträge im Gerätetreiber "Mass Storage Driver" und "Digital Camera DISK device" (die ja beide erschienen, wenn ich den mp3-Player angestöpselt hatte) entfernt.
    Habe mal den Ordner mit den oben genannten extrahierten "Treiber-Dateien" auf Diskette gezogen.
    Also: Neustart, mp3-Player an USB und wie gewünscht die Meldung "neue Hardwarekomponente gefunden". Option Position angeben, weiter. Es wird eine lange Liste mit Herstellern und zugehörigen Treibern angeboten, in der wieder der verdächtige "Mass Storage Driver" und "Digital Camera DISK device" angeboten wird. Dann auf das Diskettenlaufwerk verwiesen, entsprechenden Ordner markiert, aber: Sucht nach *.inf-Dateien. Da auf der Diskette aber keine sind, folgt die Meldung "An der angegebenen Position wurden keine Hardwareinformationen gefunden." Sind ja auch "nur *.sys bzw. *.pdr-Dateien drauf.
    Habe das Ganze mehrmals probiert, auch mit "besten Treiber suchen". Inzwischen stürzt mir die Kiste JEDESMAL ab, wenn ich nach Neustart den Player einstecke! :mad:
    Hab ziemlich die Schn.... voll von der stundenlangen, nutzlosen Ausprobiererei, vielleicht fehlt ja nur der eine entscheidende Klick, aber ich hab den Eindruck, dass meine Kiste irgendetwas anders macht, als es sein soll!?
    Am Besten gebe ich das Ding doch zurück und sehe mich nach nem anderen um. Haben andere Player möglicherweise Treiber, mit denen WIN 98 besser klar kommt?
    Trotz der momentanen Verärgerung vielen Dank an Robin und Paul, vielleicht kommt ja doch noch ein entscheidender Tipp!?
    Gruß


    Bernd

  • Re: USB-Treiber für mp3-Player geht nicht


    Hi Kangaroo,


    habe die gleiche Odyssee hinter mir, denke aber, ich kann Dir helfen.


    Der Fehler war bei mir einfach folgender: die Datei StUms.inf war nicht up to date.
    Soll heißen, der i.beat fun meldete sich bei mir mit der Kennung "VID_066F&PID_8320", aber dafür war kein Eintrag in dieser INF-Datei - DANKE TREKSTOR!!!!:mad:


    Somit wußte der HW-Assistent von Win98 natürlich nicht weiter.:question:
    Lösung: einfach eine solche Zeile per Hand einfügen (keine Panik, ist nicht so schwer).


    Das Problem dabei ist nur, die Kennung des Geräts rauszubekommen, weil Win98 ja nicht gerade gesprächig ist. Aber zum Glück legt der HW-Assistent die Kennung auch dann in die Registry, wenn kein Treiber gefunden wurde.
    Man findet sie unter HKEY_LOCAL_MACHINE->Enum->USB. Da stehen aber im Allgemeinen schon einige Einträge, also welchen nehmen.
    Ganz einfach:
    das Gerät entfernen, die Registry unter HKEY_LOCAL_MACHINE->Enum->USB öffnen,
    das Gerät anstöpseln und nach mißlungener Treiberinstallation das Registry-Fenster
    aktualisieren per F5 - voila, der neue Eintrag beschert uns die gewünschte ID (in
    meinem Fall eben die "VID_066F&PID_8320").
    Jetzt noch schnell die Datei StUms.inf im Editor (Notepad) öffnen und unter der Rubrik
    [Microsoft] eine der vorhandenen Zeilen "%USB\Generic..." kopieren und nur die Kennung am Ende der Zeile durch die in der Registry gefundene ersetzen.
    Speichern und wenn jetzt der HW-Assistent wegen des Treibers anklopft, dann können wir ihm auch wirklich sagen, wo er einen findet.




    Jetzt aber noch mal für alle zum mitschreiben:



    0. Sicherstellen, daß das Gerät nicht mehr regstriert ist
    (Gerätemanager und das USB-Gerät mit dem ? oder ! anklicken und dann "ENTFERNEN"
    klicken; Gerät abstecken; neustarten)


    1. Regedit starten (START->Ausführen, dann regedit+<ENTER> eingeben)
    2. Navigieren zu HKEY_LOCAL_MACHINE->Enum->USB (muß ausgeklappt sein, so daß man alles
    drunter sieht)
    3. Gerät anstecken und automatische HW-Erkennung laufen lassen
    4. Wie wahrscheinlich schon 1000mal probiert "Nach einem besseren Treiber...suchen" anwählen
    und die gleiche Enttäuschung erleben wie zuvor, weil in dem ausgewählten Verzeichnis
    (da, wo man die Dateien von Trekstor hin extrahiert hat) angeblich "Keine
    Hardwareinformation gefunden wurde".
    5. Den HW-Assistenten beenden
    6. Jetzt in dem noch offenen Registry-Fenster F5 drücken und es erscheint ein neuer
    Eintrag unter HKEY_LOCAL_MACHINE->Enum->USB (bein mir war es "VID_066F&PID_8320").
    7. Die Datei StUms.inf mit dem Editor (Notepad) öffnen.
    8. Unter [Microsoft] eine bereits existierende Zeile "%USB..." kopieren und nur die
    Kennung am Ende der Zeile durch die neue ersetzen.
    Bei mir war das vorher:


    [Microsoft]
    ; Use USBMSC IDs
    ;
    ; Sigmatel MSCNMMC
    %USB\Generic.DeviceDesc%=Generic.install,USB\VID_066f&PID_8004
    ; Sigmatel MSCNSM


    und nachher:


    [Microsoft]
    ; Use USBMSC IDs
    ;
    ; Sigmatel MSCNMMC
    %USB\Generic.DeviceDesc%=Generic.install,USB\VID_066f&PID_8004
    %USB\Generic.DeviceDesc%=Generic.install,USB\VID_066F&PID_8320
    ; Sigmatel MSCNSM


    Die beiden Zeilen %USB\Generic..." unterscheiden sich also nur in den letzten 4 Ziffern.


    9. Speichern und Notepad schließen.
    10. Über den Gerätemanager (rechter Mausklick auf ARBEITSPLATZ->Eigenschaften->
    Gerätemanager) das Gerät mit dem ? oder ! doppelklicken (hieß bei mir <USB PRODUCT> ) und Treiber aktualisieren anklicken.
    11. Wie bisher "Nach einem besseren Treiber...suchen" und das bisherige Verzeichnis angeben
    und - hoffentlich - endlich die Installation genießen...:thumbup:


    Go for it...

  • Re: USB-Treiber für mp3-Player geht nicht


    Hallo kiloecho!


    Ich denke nicht, dass du Kangaroo helfen konntest, da dieser Schreibwechsel zwischen mir, _Hotti_ und Kangaroo schon 5 Monate zurückliegt. Trotzdem Danke für deine Unterstützung. Vielleicht kann ein Moderator oder Administrator ein Thema mit Problemösungen öffnen; da könnte u.a. deine Problemlösung stehen ;-)


    Gruß Paul

    Haben Sie Lust auf Ferienwohnungen in Masuren?
    Bitte melden Sie sich an, um diesen Link zu sehen.
    7 Ultimate 32 bit
    500 GB#GA-P35-DS4 Rev. 2.0#Intel C2D 2,4GHz
    HIS HD3850 IceQ 3 Turbo 512 MB
    2 GB RAM
    16MB/s#FF 3.x


    bzw.


    IBM Thinkpad T61 | 2x2,2 GHz | 4 GB RAM | VISTA Ultimate 64 bit MCE | NVIDIA Quadro NVS 140M 128 MB | Wlan (agn) | Bluetooth 2.0

  • Re: USB-Treiber für mp3-Player geht nicht


    Moin moin,


    also wie wodnik91 und _Hotti_ schon sagten, lösch erstmal alle Treiber vom MP3 Player (dabei MP3 Player angestöpselt lassen und erst nach dem löschen abstöpseln)


    Lad dir das runter: Bitte melden Sie sich an, um diesen Link zu sehen.
    Original Seite: Bitte melden Sie sich an, um diesen Link zu sehen.


    Installiere es und dann startest du dein PC neu, nun stöpselst du deinen Mp3 Player wieder dran und dann müsste er wieder nach der Hardware suchen


    dabei wählst du als Pfad: C:\Windows\inf aus.


    Nun sucht er den neuen Treiber - und voila es klappt :) (hoffentlich :exclam: )



    Viel Spaß ~


    Editiert am 13/6/2006 von Feurigel


    Editiert am 13/6/2006 von Feurigel

Jetzt mitmachen!

Sie haben noch kein Benutzerkonto auf unserer Seite? Registrieren Sie sich kostenlos und nehmen Sie an unserer Community teil!